Unable to Activate Account

Product

Full PreVeil, PreVeil Express, iOS, Android

Common Causes

  • Malformed key

  • Network connection issue

  • Expired account claim

Invite by your administrator

Workaround

  1. Uninstall PreVeil with key removal and reinstall

  2. Have the administrator delete your account in the Admin Console

  3. Send a new invite

  4. Retry account activation

Invite by another PreVeil user or self-service

Enter a technical support ticket requesting account deletion and then try again.

Network Connection

Open the Key Menu, run a diagnostic and look for connection issues. Please see the System Implementation Guide for information on network configuration for PreVeil.

Expired Account Claim

Invitations by an organization administrator are valid for two weeks at which time they become invalid, and the administrator may renew the invite.

Self-service activations require an account validation by email, and additionally for PreVeil Express with SMS. These validations will expire after 15 minutes. If your account claim has expired contact PreVeil Support to renew your account activation.

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