Users invited to an Organization that disappeared

This article explains why users who are invited to your organization will disappear from the Admin Console Users page. We will also go over when a user’s invite is about to expire and how to renew the expiration time.

Cause

Users invited to the organization have a pending status until the account is claimed. If an invited user does not claim their account within a two-week timeframe then the invitation expires and the pending user is removed from the Users page.

Solution

Method One, Add the User

Re-add the user to the organization. For full instructions please see Adding a User.

Method Two, Resend Invite to Pending User

 

Note: There might be instances where the user’s invitation is about to expire and is still in the Users section of the Admin console. In order to resend another invite follow the step below.

An Admin can avoid needing to re-add the users by resending the invite to the pending user(s). In the users section of the Admin console tick the checkbox on their name and click the RESEND INVITE button. Not only does it send another invite email but it resets the expiration time another two weeks.

 

If you need further assistance please submit a ticket at the following link https://preveil.atlassian.net/servicedesk/customer/portal/2/create/10058  

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